Jump to content
  • Sign Up to reply and join the friendliest Watch Forum on the web. Stick around, get to 50 posts and gain access to your full profile and additional features such as a personal messaging system, chat room and the sales forum PLUS the chance to enter our regular giveaways.

Sunday Young Guns (Post 1990)


Recommended Posts

  • Replies 26
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Popular Posts

Freshly serviced and in mint condition!

Monaco day today   

I bought this Accurist MS906S two or three years ago out of curiosity more than anything else.  Amazon were knocking them out for £45 which is a ton of watch for the money.  The Miyota movement is so well regulated it's accurate to within a couple of tenths of a second per day.  I use it as a kind of posh beater :)

accurist-ms906s.jpg 

  • Like 5
Link to post
Share on other sites
19 minutes ago, ong said:

Parnis sterile GMT homage this morning

http://i1014.photobucket.com/albums/af261/g4gzg/Mobile Uploads/2016-09/IMAG0945_1_zps1hnbdhs0.jpg

Photobucket still not showing properly. Is this something I'm not doing ?

Copy and paste the img link instead I have the same problem the last couple of weeks hope it helps 

Link to post
Share on other sites

I have recently been acquiring a number of mechanical and quartz Accurist watches from a watch guy who bought the stock of a defunct jeweller's shop that had been an Accurist stockist. I reckon that I now have a pretty good collection of Accurist watches, covering the whole of the company's history, and to top it off I couldn't resist buying this aviator-style analogue/digital chronograph from Argos a couple of weeks ago. The watch was already heavily discounted, and then for some reason, Argos decided to temporarily reduce the price still further, so I got the watch for £39.99. 

 

15-5396908-AVW642X.jpg

(Pic from Argos.co.uk)

  • Like 4
Link to post
Share on other sites

 

http://s1014.photobucket.com/user/g4gzg/media/Mobile Uploads/201609/IMAG0944_1_zpsiawzgfrk.jpg.html

http://i1014.photobucket.com/albums/af261/g4gzg/Mobile Uploads/2016-09/IMAG0944_1_zpsiawzgfrk.jpg

Thanks for the suggestion but neither direct image or the img links work on my Android phone. Reckon I need a new photo hosting app ..

 

 

Edited by ong
Link to post
Share on other sites

I'm not usually one for swapping watches multiple times per day (unlike some of you weirdos :laugh:) but I've been sorting through a few different pieces today and organising some new storage.  I've just re-discovered the excellent Poljot Aviator I and have swapped over to that for this afternoon, not caring in the least that it looks like a Fortis Pilot :tongue:  Might actually give the Chris Ward some time off and wear this for the rest of the week. 

poljot-aviator.jpg

  • Like 4
Link to post
Share on other sites
14 minutes ago, ong said:

 

http://s1014.photobucket.com/user/g4gzg/media/Mobile Uploads/201609/IMAG0944_1_zpsiawzgfrk.jpg.html

http://i1014.photobucket.com/albums/af261/g4gzg/Mobile Uploads/2016-09/IMAG0944_1_zpsiawzgfrk.jpg

Thanks for the suggestion but neither direct image or the img links work on my Android phone. Reckon I need a new photo hosting app ..

 

 

Not sure if the first link has an error in it somewhere but I can't get that to work at all.  PB just says the page doesn't exist.  The second link works fine if I paste it into my browser.  However, if I try to link to the image from the forum, it fails.  Is there a setting in PB somewhere that protects images from being copied/shared?

  • Like 1
Link to post
Share on other sites
5 minutes ago, rhaythorne said:

Not sure if the first link has an error in it somewhere but I can't get that to work at all.  PB just says the page doesn't exist.  The second link works fine if I paste it into my browser.  However, if I try to link to the image from the forum, it fails.  Is there a setting in PB somewhere that protects images from being copied/shared?

Thanks. I'll take a look in the PB settings.   

Link to post
Share on other sites
6 minutes ago, rhaythorne said:

Not sure if the first link has an error in it somewhere but I can't get that to work at all.  PB just says the page doesn't exist.  The second link works fine if I paste it into my browser.  However, if I try to link to the image from the forum, it fails.  Is there a setting in PB somewhere that protects images from being copied/shared?

Some info from @Krispy in this thread.

:)

  • Like 2
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...