Jump to content
  • Sign Up to reply and join the friendliest Watch Forum on the web. Stick around, get to 50 posts and gain access to your full profile and additional features such as a personal messaging system, chat room and the sales forum PLUS the chance to enter our regular giveaways.

Casio Aq-310G Not Running Correctly


Recommended Posts

My other half has a Casio AQ-310g ( Digital and Analogue display) that she is rather attached to as it belonged to her grand dad.

I recently put a new battery in and it seemed to be working fine, the digital display keeps time as you would expect but the analogue hands lose time. i was under the impression this didnt happen with quartz watches? Could it just be a case of a dodgy battery or something else that can be sorted out?

Thanks for any help.

Link to post
Share on other sites

You might need to perform a reset procedure after the battery change. Quite simple, all you need to do is bridge between the battery and a contact marked "A/C" for a few seconds using tweezers or a paper clip. Worth a try anyway.

Link to post
Share on other sites

I have had problems with Casios when using a cheapo type battery , the sort you get about 10 for a quid .

I've changed the battery for a half decent one and the problem has been solved , not saying you've used a cheaper type battery but if you have and you are going to open it up to do a reset it might be worth changing the battery to .

cheers

Andy

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...